Captcha Display problem

Sep 4, 2008 at 10:37 AM
Hai Guys..


             I add the sharp piece captcha control in my .net applicatio,but when i put the control in the aspx page it wont seen in the page when it loads.what is the issue in that.please help me immediately.its urgent.
Coordinator
Sep 4, 2008 at 11:43 AM
Can you ckeck if you have the captcha http handler registered in web.config?$0If you have it, please give some relevant code snippets in order to help you out.$0$0Thanks,$0$0Raul$0
Sep 4, 2008 at 12:36 PM
Ya i will send the http handler in my web.config.


<httpHandlers>
            <remove path="*.asmx" verb="*"/>
            <add path="*.asmx" verb="*" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/>
            <add path="*_AppService.axd" verb="*" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/>
            <add path="ScriptResource.axd" verb="GET,HEAD" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/>
            <add path="atlasbatchcall.axd" verb="*" type="Microsoft.Web.Services.MultiRequestHandler" validate="false"/>
            <add path="atlasglob.axd" verb="*" type="Microsoft.Web.Globalization.GlobalizationHandler" validate="false"/>
            <add path="*.asbx" verb="*" type="Microsoft.Web.Services.ScriptHandlerFactory" validate="false"/>
            <add path="gradientbutton.axd" verb="*" type="SharpPieces.Web.Controls.GradientButtonProvider, SharpPieces.Web.Controls.DynamicImage, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null" validate="true"/>
            <add path="dynamicimage.axd" verb="*" type="SharpPieces.Web.Controls.DynamicImageProvider, SharpPieces.Web.Controls.DynamicImage, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null" validate="true"/>
            <add path="captchaimage.axd" verb="*" type="SharpPieces.Web.Controls.CaptchaImageProvider, SharpPieces.Web.Controls.DynamicImage, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null" validate="true"/>
        </httpHandlers>


This is the http handler code in web.config.Kindly help me .is there any library or else i want to add in my prjct.
Coordinator
Sep 4, 2008 at 3:36 PM
you handlers seem to be registered ok.$0Can you also provide the aspx/ascx & cs code that you use to generate the image? This would help us test the problem on our side.$0$0$0$0$0$0$0
Sep 5, 2008 at 4:58 AM
<piece:CaptchaImage ID="imgCaptcha" runat="server">
                    </piece:CaptchaImage>

i didnt write any code in the aspx page.only put the control in the aspx page .thn the dll will be registerd in the assembly.but i cant view the captcha image.what is the pbm here?
Sep 5, 2008 at 6:38 AM
<piece:CaptchaImage ID="imgCaptcha" runat="server">
                    </piece:CaptchaImage>

i didnt write any code in the aspx page.only put the control in the aspx page .thn the dll will be registerd in the assembly.but i cant view the captcha image.what is the pbm here?
Coordinator
Sep 5, 2008 at 6:49 AM
$0<piece:CaptchaImage ID="CaptchaImage1" runat="server" ReadnessLevel="Hard" TextAllowsDigits="True" TextLength="7" SizeType="Specified" Width="180px"> <Text Color="Purple" Font="Arial, 28pt, style=Bold" HorizontalAlign="Center" VerticalAlign="Center" /> </piece:CaptchaImage>$0$0$0$0Try this approach. It's taken from the demo, so it should work.$0$0$0
Sep 5, 2008 at 7:26 AM
I given the same code in design side but the captcha willnot view.is any class library for the sharppiece need to be add to the page.


Coordinator
Sep 5, 2008 at 8:50 AM
$0You can download the dmeo website.$0$0Try comparing what's in there for captcha image, and what's in your project.$0
Sep 5, 2008 at 11:09 AM
I download the demo site and check it .But in their wrk they add class library for all the controls.Shall i also add the class library in m,y pjct.
Coordinator
Sep 5, 2008 at 12:51 PM
A solution would be to add all the references until it works, then remove 1 by 1.
Sep 6, 2008 at 5:45 AM
how i add solution to each control.please send some code help to me.
Sep 8, 2008 at 7:02 AM
I add all refrences and tried to work it.abut again the same problem exists.Thae captcha willnot display.

If any problem occurs in the patch of  the control i added in my application.

First i add the dll into my application and put the captcha control in my page and tried to load it.but the im age wont display.all the refrences and handlers are added in the application.but i dont get the error.Is any issue if it loads in masterpage.Please help i need it urgently.

Thanks Sreejith
Coordinator
Sep 12, 2008 at 4:20 PM
Edited Sep 12, 2008 at 4:22 PM
Hi. I think the best solution is for you to make a very small web site or web app project where try to use a captcha, make a zip and send it to contact (at) sharppieces.com . It shouldn't take you more than 1hr.

Alex