Version 2.3 HTTP Handler Configuration Error

Dec 3, 2008 at 5:50 AM
I'm diggin the new release (2.3) and assembly however i'm having some serious issues getting the paths to add in the web.config.
I'm trying to add a captcha control to my page, and it adds just fine and everything builds successfully, however at runtime i'm getting this configuration error:

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 
Parser Error Message: Could not load file or assembly 'SharpPieces.Web.Controls.DynamicImage, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.
Source Error: 
Line 101:        Line 102:        <!-- Added for captcha key -->Line 103:        <add path="dynamicimage.axd" verb="*" type="SharpPieces.Web.Controls.DynamicImageProvider, SharpPieces.Web.Controls.DynamicImage, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null" validate="true" />Line 104:      Line 105:      </httpHandlers>

So, i decided to download the demo that came with this current (ver 2.3) release and see if i could see the error of my ways and guess what:

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 
Parser Error Message: Could not load file or assembly 'SharpPieces.DemoApp, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.
Source Error: 
Line 11: Line 12:       <httpHandlers>Line 13:         <add path="themesdataprovider.axd" verb="*" type="SharpPieces.DemoApp.LiveGrid.ThemesDataProvider, SharpPieces.DemoApp, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null"Line 14:           validate="true" />Line 15:         <add path="actionsdataprovider.axd" verb="*" type="SharpPieces.DemoApp.LiveGrid.ActionsDataProvider, SharpPieces.DemoApp, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null"
Source File: C:\Documents and Settings\easton\My Documents\Visual Studio 2008\WebSites\SharpPieces.DemoApp\web.config    Line: 13 


Same error. So i'm kinda stuck on this one. Is anyone else having this problem? Doesn't anyone have an idea of what i can do to get this to work?

Thanks for your support!
Easton
Oct 16, 2009 at 2:57 AM

Hi Easton,

I am suffering to the same problem. Did you get this to work? Please reply your solution if any.

Thanks in advance.

Nov 12, 2010 at 6:42 PM

Could do with a hand , I have the same issue

 

was anyone able to fix this issue ??

 

Thanks

Nov 12, 2010 at 7:13 PM

I just ended up using a captcha solution from http://www.captcha.net/.

I've been very happy with their product.

Apr 30, 2011 at 9:24 AM

Hi,

try this

<add path="dynamicimage.axd" verb="*" type="SharpPieces.Web.Controls.DynamicImageProvider, SharpPieces.Web.Controls.DynamicImage, Version=2.3.0.0, Culture=neutral, PublicKeyToken=null" validate="true" />


Regards

George